Back
Maintenance

Virtualization host software upgrades

Completed 29 Jan at 02:10am MST.

Main website SSO Jellyfin Discord Bot
Updated

Upgrades completed successfully.

Posted 29 Jan at 02:10am MST.
Completed

Maintenance completed

Posted 29 Jan at 02:10am MST.
Started

Everything will be down for a short period

Posted 29 Jan at 01:57am MST.