Back
Maintenance

Hardware replacement

Completed 17 Feb at 12:30am MST.

Jellyfin
Completed

Maintenance completed

Posted 17 Feb at 12:30am MST.
Started

Services relying on high capacity storage will be unavailable for a short period for hardware upgrades.

Posted 17 Feb at 12:00am MST.